Kirjoittaja Aihe: 407 - Moottorin vikavalo palaa (EW)  (Luettu 2041 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

gli

  • Vieras
407 - Moottorin vikavalo palaa (EW)
« : 29.08.2012, 09:47:26 »
Auto: 2006 407 SW 2,0 Executive.

Auto oli pari päivää merkkikorjaamolla takapuskurin korjausmaalauksessa, ja jostain syystä nuo pari päivää ovat sitten säikäyttäneet moottorin vikavalon palamaan. Näyttö kertoo, että "Depollution system faulty". Onko kyse vain normaalista huonosta tuurista, vai voiko puskuriremonttiin liittyä jotain, mikä saisi ongelman aikaan? Valo ei palanut autoa korjaamolle viedessä eikä ole koskaan aikaisemminkaan palanut. Kyse oli vakuutushommasta, eli ei kyllä viitsisi maksella omasta pussista mistään asiaan liityvästä.

gli

  • Vieras
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #1 : 29.08.2012, 19:16:17 »
Vastataan tässä nyt sitten itse itselle. Vikakoodit luettiin ja nelospytyssä näytti olleen jokin sytkähäiriö. Neuvottelun jälkeen tultiin siihen tulokseen, että häiriö saattoi todennäköisimmin johtua auton pienestä siirtelystä pihalta maalaamoon. Koodit nollattiin lopulta korikorjaamon laskuun, eikä vika ole ainakaan vielä uusiutunut. Todettiin siinä sitten vielä yleisesti, että nykyautot eivät oikein tykkää noista muutaman metrin siirtelyistä ja hetken käytöistä.

Kreivi

  • Käyttäjä
  • *
  • Viestejä: 6
  • Peugeot 406 & 407
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #2 : 01.01.2019, 15:26:06 »
Auto: 2004 407 SW 1,8 (6FZ, EW7J4).

Lähtötilanne oli MIL-valo joka nollattiin 70km ajettuna Motonetin "motomaatilla". Tällöin muistissa oli moottoriin liittyviä vikakoodeja seuraavasti;

- P0351 ja P0352, sytytyspuolan molemmat piirit
- P0202, P0204, P0203, P0201, suuttimien virtapiiri avoin
- P2143, Pakokaasujen takaisinkierrätyksen ilmanvaihdon ohjausvirtapiiri avoin.

Koodit nollattiin ja ne nollautuivat, mutta lyhyellä ajolla ne tulivat takaisin(oletan, että koodit aktivoituvat tilanteessa jossa esim. hidastetaan Stop-risteykseen). MIL-valo ei fyysisesti pala. Vikakoodin lukija kertoo sen palavan, mutta mittaristossa se ei näy missään tilanteessa(polttimo pimeä?)

Tämän jälkeen tulpat, puola, moottorinlämpöanturi ja ilmansuodatin vaihdettiin. Vanhat tulpat olivat jokin älytön eripari sarja ja kärkivälitkin olivat yli 1.5mm verrattuna noihin uusiin, joiden kärkiväli on jopa alle 1mm. Vanha ilmansuodatin oli tukkoinen ja vanhassa puolassa oli yksi tulpan navoista hapettunut käyttökelvottomaksi.

Jo ennen näitä töitä mitattiin pakoputkelta erinomaiset päästöarvot.

Töiden jälkeen laitoin oman vikakoodinlukijani kippoon kiinni ja kävin heittämässä pari testilenkkiä nollattuani vikakoodit. Laitoin vikakoodilaukaisun tallennukseen ja sieltä sain vaihtelevasti ulos vikakoodia P0351 ja P0352, puola. Välillä molemmat, välillä vain toinen. Välillä toinen kehittyvissä koodeissa, joissa usein näkyi myös koodi P2143, egr.

Loppuu ymmärrys, etenkin nyt kun tuolta ei enää juuri muita koodeja tule kuin tuosta puolasta. Auto käy hienosti, jopa erinomaisesti, mutta leimaaminen ei onnistu koska MIL-valo lukijan mukaan palaa, kuten sen pitäisikin palaa kun vikamuistissa on koodeja.

Sekundäärisenä kysymyksenä tiedustelisin, että missä tässä laitteessa on mittaristolle menevä moottorin lämpötila-anturi? Mittariston viiksi ei edes heilahda, vaikka OBD:n kautta reaalidatassa on ihan oikeat lukemat, jotka tulevat kaiketi ECUn anturin kautta?

Ystävällisin terveisin,
Kreivi

Kreivi

  • Käyttäjä
  • *
  • Viestejä: 6
  • Peugeot 406 & 407
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #3 : 01.01.2019, 16:55:36 »
EDIT:

MIL-valon palamattomuus vika paikannettu.
Lämpömittarivika melkovarmasti paikannettu.

Toi kaveri jolta tuo auto on haettu on ilmeisesti yrittänyt korjata vikaa vetämällä reilun kerroksen sähköteippiä erinäisten vika-LEDien päälle mittariston piirilevyssä. Siinä samalla tämä typerä hölmö(terveisiä turkkuseen, jos luet tätä) on nähtävästi runnonut lämpömittarin toimimattomaksi. Mittaristo täytynee siis johonkin väliin varmaan vaihtaa, kun ei tonne mittariston(VDO) sisälle varmaan pahemmin saa varaosia.

ONKO PORUKALLA KOKEMUSTA ns. järjestelmäreleestä, joka ilmeisesti syöttää "isot virrat" likimain kaikelle, mahtaisko tuo olla tämän puolavian alkuperä? Miten pösössä OBD-järjestelmä haistelee puolavikaa? Mittaako tuo kipinän käyttämää virtaa vai...?

EDIT2 Kuuluuko bensapumpun käydä kokoajan, myös virrat päällä moottori sammuksissa?

Kreivi

  • Käyttäjä
  • *
  • Viestejä: 6
  • Peugeot 406 & 407
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #4 : 03.01.2019, 22:41:32 »
Jatkan yksinpuheluani, jostain syystä en saa edeltäviä viestejä muokattua.. Konsistenssin nimissä olisi parempi niin, mutta kirjaillaan nyt tähän alle.

Tilanne 03.01.2019:
- Lämpömittari ei toimi, varaosa tulossa foorumilaiselta.
- MIL-valo ja muut mittariston jouluvalot saatu näkyviin poistetun sähköteipin myötä
- Kakkoslambdan liitin rikki, ei mitattavaa vaikutusta toimintaan mutta kuitenkin.
- Bensapumppu pyörii kokoajan virrat päällä
- Parkit ei pala, polttimot ehjät.
- Monitoiminäyttö lakkaa toimimasta välittömästi kun kabiini lämpenee nollan asteen paremmalle puolelle
- Autolla ajettu onnistuneesti lähes 200 kilometriä vaihtelevilla nopeuksilla. Ei vikakoodeja.

SITTEN TAPAHTUI JOTAIN ERIKOISTA!!

Sammutin moottorin kotipihaan. Ennen sammutusta MIL-valo ei palanut. Kuitenkin, 15 minuuttia myöhemmin kun laitoin kipon käymään niin tuttu MIL-valo jäi jälleen palamaan, muistissa tutut P0351, P0352 ja P2143 koodit. Puola ja EGR. MIL-valo päällä ajettu 0 kilometriä.

Mä olen nyt puolen tusinaa kertaa toistanut tämän niin, että reaalidatasta katon, että auto on closed loopissa, eikä havaittuja vikakoodeja ole ennen moottorin sammuttamista.

MIKSI moottorin sammuttaminen avaimesta laukaisee vian, joka tallentuu välittömästi muistiin? MIKSI sillä voi ajaa 200 kilometriä ilman vikoja, mutta parkkiin sammuttaminen kirjoittaa muistiin vikakoodin?

BSM-purkki on tilattu, mutta jotenkin skeptisesti suhtaudun siihen, että voiko tämä olla siitä lähtöisin. ECU toimii muuten kuten pitääkin, eikä mikään viittaa BSI ongelmaan.

Kreivi

  • Käyttäjä
  • *
  • Viestejä: 6
  • Peugeot 406 & 407
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #5 : 05.01.2019, 23:25:18 »
Yksinpuhelu jatkukoon, lienee ihan paikallaan vähintäänkin dokumentoida tämä keissi ihan siltä varalta, että joku joskus painii vielä saman ongelman kanssa.

Tänään vaihdettu UUSI Sitronen Oy:n toimittama BSM-purkki paikalleen sillä lopputuloksella, että auton moottori ei enää sammu normaalisti avaimesta kääntämällä lainkaan. Itseasiassa kun moottori käy, ei avaimesta kääntämällä tapahdu yhtään mitään. Eli siis puhallin pyörii, monitoiminäyttö jää päälle, sähköikkunat toimivat, mittaristo toimii, jne. Virtalukko toimii kuitenkin normaalisti kun moottori EI KÄY!

Siispä käänsin avaimen nollille, otin avaimen taskuun ja käväisin tupakalla.. Kun palasin takaisin auto edelleen käydä rympsytteli iloisesti. Emäntä tuli samaan aikaan kauppareissulta, tiedustellen että "joko toimii?.. Vastauksen muodossa heiluttelin avainta kädessäni.  :o ??? ::)

Sammutin moottorin "tumppaamalla" vaihdetta vasten, ei vikakoodia. Moottori on siis sammutettavissa ilman, että OBD rekisteröi vikakoodeja. Jänskää.

Tämän jälkeen otin ja asensin vanhan BSM-purkin paikalleen sillä seurauksella, että auto sammuu nyt avaimesta kääntämällä, tosin, avaimesta kääntämällä sammuttaessa EDELLEEN rekisteröityy samat vikakoodit!!!

Sitten sain ajatuksen; mitäpä jos sammutan moottorin "tumppaamalla" vaihdetta vasten vanhalla BSM-purkilla? No jep, ei vikakoodia, ei MIL-valoa!

Päivän kysymykset;
1. Miten BSM-purkki voi vaikuttaa virtalukon toimintaan?
2. Miten voi olla, että "väärin" sammuttamalla OBD ei rekisteröi vikakoodia? Mietin, että voiko virtalukko olla sillä tavalla viallinen, ettei eculle mene tietoa sammutuksesta ennen kuin releet naksahtavat auki? Eli, että puolalta häviää +12v ennen kuin ecu lakkaa ohjaamasta kipinää?
3. Miten tuollainen "multipleksattu" nykyvirtalukko voidaan testata toimivaksi?
4. Mikä on todennäköisyys sille, että UUSI ALKUPERÄINEN BSM-rasia on valmistusvikainen?

Timppa71

  • Käyttäjä
  • ******
  • Viestejä: 1 217
  • 2x Peugeot, 2x Renault
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #6 : 06.01.2019, 10:42:08 »
Onpas mielenkiintoinen ongelma. Muutama  osittainen kommentti noihin viimeisiin kysymyksiisi, eli

Ei tuo virtalukko ole mitenkään sen kummemmim multiplexattu. Pitäisi varmasti varmistaa sähkökuvista mutta muistaakseni esim. bensa V6 mallin virtalukosta lähti vain muutama johto, toinen oli Vcc tieto ja toinen varmaankin starttaus. Tieto avaimen asennosta menee sitten BSI boksille tai jollekin muulle ohjainlaitteelle josta tieto sitten jaetaan auton muille yksiköille väylän kautta. Eli siinä mielessä virtalukko on aika "yksinkertainen" osa.

Olisikohan niin, että tuollainen uusi bsm-boksi pitäisi jotenkin koodata sopivaksi autoon, varsinkin jos on ihan uusi? En ole kyllä tästä ihan varma. Mutta ainakin joskun olen siis muuttanut joitain auton asetuksia (aktivoinut jotain sellaista ominaisuutta mitä autossa ei siis ollut) jonka jälkeen autoa ei enää saanut käyntiin ennen kuin palautti tuon väärän konfiguraation takaisin. Samaan aikaan tuolta konetilan ohjauslaitteesta (olisiko ollut sitten bsm?) kuului jotain releiden naksetta) Eli jotain merkitystä oikealla bsm-boksin konfiguraatiolla saattaa kyllä olla.

Kreivi

  • Käyttäjä
  • *
  • Viestejä: 6
  • Peugeot 406 & 407
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #7 : 06.01.2019, 11:30:08 »
Onpas mielenkiintoinen ongelma. Muutama  osittainen kommentti noihin viimeisiin kysymyksiisi, eli

Käsitykseni mukaan BSM:ää ei tarvitse, eikä edes sinänsä voi ohjelmoida. Se on periaatteessa BSI:n alainen orjakortti ja BSI on sitten se autoon ohjelmoitava pääkortti joka ohjaa kaikkea ja joka pitää ohjelmoida erikseen jokaiseen autoon. BSM pitäisi käydä ristiin kaikkien autojen välillä, kunhan tuo koodi "BSM L02-00" täsmää, tämä oli myös myyjän näkemys(myyjä myy Citroën alkuperäisosia, sattuneesta syystä C6 sitikan BSM on sama kuin 407 pösön).

Mutta, mä en nyt näe tässä sitäkään mahdollisuutta, että BSI olisi viallinen koska mulla on kaksi neitseellistä BSM:ää, uusi ja vanha, joista toinen kuitenkin toimii pidemmälle kuin toinen. Kytkiksiin/kaavioihin en ole vielä tarkemmin syventynyt, mutta huvin ja urheilun vuoksi mittasin yleismittarilla tuon uuden BSM:än ja sieltä menee "kylmänä" virrat suoraan läpi(ns. jatkuvuus +12v nastalta sulakkeille ja sulakkeiden takana oleville pinneille, eli mun järjellä ajelateltuna releet ovat kiinni vaikkei sinne syötä virtaa mistään. Osittain tämä kaiketi selittää miksei moottori sammu avaimesta kääntämällä, mutta sitä en ymmärrä miksei virrat häviä muualta, siis sellaisilta osastoilta, jotka ei käy BSM:n kautta, vaan ovat suoraan BSI:n alaisuudessa. Pitää vielä vertailun vuoksi mitata tuo vanha BSM.

Oletan, että tuo uusi BSM on viallinen, se ei ilmeisesti olisi ensimmäinen, mutta pirun huonoa tuuria kuitenkin.

Oletan, että virtalukossakaan ei ole mitään vikaa. Jos IGN ja ACC välillä olisi pieni katkos, niin se saattaisi periaatteessa selittää nuo vikakoodit, mutta en ole sellaista käyttämilläni metodeilla löytänyt. Eikä tuo epämääräinen toiminta uudella BSM:llä voi johtua virtalukosta, kun lukko kuitenkin toimii normaalisti vanhalla BSM:llä.

Alkaa ideat loppumaan, tästä tuskin selviän voittajana mutta tuo auto on ollut sen verran edullinen noin niinku muuten, että taidan ihan periaatteen vuoksi korjata tai viime kädessä korjauttaa sen.  :o

Timppa71

  • Käyttäjä
  • ******
  • Viestejä: 1 217
  • 2x Peugeot, 2x Renault
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #8 : 06.01.2019, 11:59:39 »
Tuo BSI-BSM yhteys kuulostaa järkevältä ja noinhan se varmasti on (taisin muuten itse juuri tuolloin käpistellä BSI:n asetuksia...).
Ja nyt kun BSI:n asetukset ovat samat niin luulisi uuden BSM:n toimivan kuten vanha. Jos ei toimi niin jotain eroa on jossain. Kuitenkin ja edelleen olen sitä mieltä, että olisi varmaan ihan hyvä käytää autoa piuhan päässä niin näkisi mitä tuolla tapahtuu, ihan oikeasti. Noiden ohjainlaitteiden takaa pystyy lukemaan aika paljon asioita joiden perusteella on helpompi päätellä missä vika on. Onko sinulla mahdollisuus laittaa auto kiinni diagnostiikkalaitteeseen (PPS / Diagbox)? Näissä nykyautoissa tuo diagnostiikkalaitteen käyttö on aika välttämätöntä vianetsinnässä, IMO  :)

JPL

  • Käyttäjä
  • ******
  • Viestejä: 4 200
  • 407 3.0 V6 Sport
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #9 : 06.01.2019, 13:17:57 »
Harmittavia vikoja. Kun avaimen jättää virtalukkoon, niin hälyttääkö piipauksella, kun avaat oven? Virtalukossa on vain kosketintiedot virralle, starttaukselle ja mikrokytkin avaimen unohtamiselle. Komppaan Timppaa, että ilman testeriä ei tuon auton vika tokene...mutta lue loppuun ja tuurilla vika on simppeli. Toki boxi uuttuuttaan saattaa olla rikki, mutta erittäin harvinaista.
Omassa 407V6:ssa on sitikan C6:sta boxi, tarrassa L02-00 ja toimii ok. Kaikki tietohan BSIn ja BSMmän välillä toimii CAN-väylää pitkin. Oheisena muutama foto.

Simmpelein vika on (voi olla tämä) yksinkertainen, eli onko polkimien yläpuolelta katsottu johtosarjan nippua huolella. Polkimet voivat hangata johtonipun eristeet ja tämä sotkee auton Cänniin. Varsinkin, jos ja kun on lämpölaitetta on korjattu ja irroiteltu originaaliasennuksia ja johtonippu on jäänyt roikkumaan. Eräs 407 HDI meinasi kerran karata tallista, kun alkoi starttaamaan itsekseen. Johtonipussa oli hankauma ja ilmenevänä vikana oli ABS ja ratin asentotunnistin. Vika olikin johtonipun oikosulku polkimiin  8).
« Viimeksi muokattu: 06.01.2019, 13:21:51, kirjoittanut JPL »
- nautiskellen nyt tästä, on pakko vilkaista vielä kerran, kun pysäköin -

SEL

  • Käyttäjä
  • ******
  • Viestejä: 1 224
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #10 : 06.01.2019, 14:45:51 »
Myöskin maadoitusvika voi aiheuttaa tällaista.
Peugeot driver since 1995,
Peugeot 3008 e-HDi 2Tronic 2012.

JPL

  • Käyttäjä
  • ******
  • Viestejä: 4 200
  • 407 3.0 V6 Sport
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #11 : 06.01.2019, 18:48:32 »
Akun vieressä M10 pulttien alla olevat maadoitusjohdot syyniin.
- nautiskellen nyt tästä, on pakko vilkaista vielä kerran, kun pysäköin -

Kreivi

  • Käyttäjä
  • *
  • Viestejä: 6
  • Peugeot 406 & 407
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #12 : 07.01.2019, 08:31:24 »
Vika ratkesi myöhään eilen illalla kun purkasin kabiinin puolelta muovia pois tieltä, kun kahtelin miten nuo johdot menevät tuolla. Kuljettajan puolelta erään muovin irroituksen jälkeen tipahti käteen n. 10m kieppi tarpeettoman paksua kaapelia. Osapuilleen keskellä 25A sulake. Lyhykäisyydessään tolla kaapelilla oli yhdistetty virtalukolta tuleva harmaa olemattoman ohut johto tarpeettoman paksun kaapelin kautta bensapumpun releeltä pumpulle menevään +12v syöttöjohtoon..

Sieltä on siis vanhasta sulakerasiasta ainakin bensapumpun rele pimeänä. Uusi sulakeradia toimii ainakin toistaiseksi erinomaisesti, kun nyppäsi vain tuolta hyppyjohdosta 25A sulakkeen irti. Sammuu, eikä herjaa puolalta vikakoodia. Vanhalla sulakerasialla ilman tota hyppyjohtoa herjasi kaikkia niitä "normaaleja" vikakoodeja mitä yleensäkin bensapösöt hajonneella BSM:llä, suuttimet, toisioilma, jne. Ei kuitenkaan puolasta tai egr-venttiilistä.

Se mitä tässä siis oli tapahtunut on, että sulakerasia oli poksahtanut ja bensapumpun rele oli ohitettu. Uudella sulakerasialla pumpulle oli tuplasyöttö, joka vielä tuuppasi virtaa virtalukolle. Siksi se ei sammunut. Toteutushan tossa on ihan syvältä, vaikka se selkeästi on toimiva ratkaisu jos bensapumpun rele laukeaa jonnekkin Norjan tuntureihin, suosittelen kuitenkin miettimään toteutuksen vähän pidemmälle :o

Homma ok, eikä pösössä edes oikeesti ollut mitään vikaa  8) Mitä nyt yksi sulakerasia mihin ei saa järkevästi releitä vaihdettua, mutta loppujen lopuksi ei tuo nyt kallis ollut, tuo rasia. Hölmöä vain maksaa satasia piirilevystä, kun vika on euron(give or take) kiinalaisessa releessä. Helpommin tämäkin silti olis mennyt, kun auton mukana olis kulkenu rehellisesti tieto, että "sulakerasia rikki, osta uus, laita paikalleen, auto halpa", eikä mitään piiloon jemmattuja johtoja tai teipattuja vikavaloja, vielä niin, että kikkailemalla hajotetaan jotain muuten toimivia komponentteja(lämpömittari, stepperiin kohdistettua väkivaltaa.. ollut kai viiksi piukassa).

Kiitokset ongelmanratkaisuun osallistuneille!

imaS

  • Käyttäjä
  • *****
  • Viestejä: 671
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #13 : 07.01.2019, 15:32:27 »
Saatko purettua vanhan osan ja kurkattua releen kuorien sisään? Ainakin 406:ssa ilmastoinnin kompuraa ohjaamaan käytetyissä piirilevylle juotetuissa releissä murtuu juotokset kotelon sisältä. Korjaantuu uudelleen juottamalla.
405 Mi16x4 -90, 406 Coupé V6 -01

cone

  • Ylläpitäjä
  • *******
  • Viestejä: 3 250
Vs: 407 - Moottorin vikavalo palaa (EW)
« Vastaus #14 : 08.02.2019, 09:57:53 »
Yhdistetty aiempaan viestiketjuun.

TEMP_POISTETTAVAKSI
Omistetut pösöttimet: 2006 607 3,0 V6 (ES9A, AM6), 2000 607 2,2 (EW12J4, ZF 4HP20), 1990 405 Mi16 1,9 (XU9J4).